Archiv für das Schlagwort (Tag): 'SVN'

Feb

28

Floatbox Plus: 1.2.13 – Probleme beim Update…

Wer einen Fehler (“parse error on line 714″) beim Update bzw. beim Installieren von Floatbox Plus bzw. bei der Aktivierung bekommen hat, der möge Floatbox Plus einfach nochmal neuinstallieren (die Einstellungen gehen nicht verloren).

Der Fehler ist durch ein “kleines” Problem beim hochladen des Updates ins SVN von WordPress.org entstanden, durch einen Konflikt war schon die neue readme.txt hochgeladen, nicht aber die eigentliche Version. So wurde statt der neuen Version die Variante aus dem “trunk” verwendet, die buggy ist und leider war es mir nicht sofort möglich den Fehler zu beheben (ich synchronisiere ein lokales SVN via SVK mit dem SVN von WordPress.org, und beim mergen gab es einen Konflikt, der nicht direkt zu lösen war *grml*). Aber nun sollte wieder alles funktionieren.

Mrz

19

KForge…

Ihr programmiert häufiger kleinere (oder auch grössere) Dinge, dann solltet ihr euch einmal das in Python geschriebene KForge genauer anschauen… KForge nimmt euch die “lästige” Kommandozeilenarbeit ab neue Subversion Repositories anzulegen und Trac dafür zu konfigurieren (auch ein MoinMoin-Wiki, ein WordPress-Blog, eine Webseite inkl. DAV-Zugriff lassen sich damit für jedes Projekt via Weboberfläche anlegen). Das WebAdmin Plugin für Trac ist äusserst empfehlenswert (am besten global installieren), da sich damit u.a. auch die Zugriffsrechte im Trac leicht anpassen lassen (in der Grundkonfiguration dürfen Gäste fast alles).

Nicht ganz so einfach gestaltet sich allerdings die Installation, wenn man gerne möglichst aktuelle Versionen der Tools einsetzen mag… Die Installtion unter Debian 4.0 (etch) scheitert an der Unverträglichkeit von KForge und Apache 2.2 (Die Authentifizierung via DAV/SVN funktioniert nicht?). Unter Debian 3.1 (Sarge) empfiehlt sich der Einsatz von Backports (z.b. für SVN, 1.4 statt 1.1 etc.), Trac sollte man aus den Sourcen selbst installieren (Der Trac 0.10.x – Backport beisst sich mit mod_python…). Damit Trac 0.10.x auch mit KForge zusammen funktioniert, muss man allerdings auch noch das Trac-Plugin anpassen (Der Versionscheck erkennt Trac 0.10.x fälschlicherweise als 0.8.x)…

Archiv

Zufällige Bilder

  • Kod: Screenshot
  • Lichttest: Maglite 6D - größter Lichtkreis
  • Philips HD4419/20: Danach...

Kommentare (28 Tage)

Sonstiges


Bloggeramt.de