Okt

22

hype it!: 0.2.0 – code rewrite (OOP)

Im Moment bin ich „gezwungenermassen“ dabei OOP in PHP zu lernen. Um nicht nur irgendwelche sinnlosen Beispiele anzupassen/(um)zuschreiben habe ich mich dazu durchgerungen das WordPress-Plugin „hype it!“ in OOP umzusetzen. Wie gesagt, ich bin gerade erst dabei mir OOP in Zusammenhang mit PHP anzueignen, und so wird sicherlich das Eine oder Andere noch nicht optimal umgesetzt sein (Vorschläge sind willkommen), aber es sollte soweit alles funktionieren.

Damit es beim Update keine Probleme gibt, habe ich noch eine „Wrapper“-Funktion drinne, damit die alte Variante des Aufrufs (erstmal) weiterhin funktioniert.

Neue Funktionen sind keine dabei, auch wenn der Versionssprung es vielleicht vermuten lässt.

Den Download gibts bei WordPress.org/ das Update sollte in den nächsten Minuten auch via Aktualisieren-Funktion in Adminpanel von WordPress zur Verfügung stehen.

2 Kommentare bis jetzt

  1. Kommentar von Eric Merten:

    die neue version erzeugt bei meinem wp 2.6.1 immer fatale fehler, wenn ich versuche das plugin zu aktivieren:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‚}‘ in /xxx/plugins/hype/hype.php on line 24

  2. Kommentar von proog:

    mmh, sieht nicht so gut aus, allerdings ist mir unklar was den Fehler verursachen könnte, in der Zeile steht nichts weltbewegendes. Könntest du mal ein paar Infos zu deinem Server liefern (php-Version/Einstellungen etc.)? Danke.

Kommentar hinterlassen

You must be logged in to post a comment.

Archiv

Zufällige Bilder

  • EX Dreadnoughts
  • Mäusepärchen: Bild 1
  • Nikon Coolpix S8100

Kommentare (28 Tage)

Sonstiges


Bloggeramt.de